Hinweis nach EU Cookierichtlinie
Diese Seite verwendet Cookies, um den Login und ungelesen Markierungen zu verwalten. Mit dem surfen auf dieser Seite erklärst Du Dich damit einverstanden, dass Cookies gesetzt werden. Mit der Option ganz unten auf der Seite "Cookies von diesem Forum entfernen" kannst Du alle Cookies, die von diesem Forum gesetzt wurden, von Deinem Computer entfernen lassen.

TCP/IP Probleme

Verbindung via aLobby bricht ab

Jetzt registrieren um mitzureden

Avatar Zwerg
keine Angabe keine Angabe

freier Siedler

Beiträge: 5
Dabei seit: 04 / 2019

Private Nachricht

11.04.2019 - 11:45 Uhr

TCP/IP Probleme

Moin,

Erstmal grossen Dank und Respekt an die Macher hier. Ist wie ein grosses Weihnachtsgeschenk für jeden Vollblutsiedler.. falls ihr Hilfe braucht (nebst den Donations), sagt Bescheid. Ich wurde hier hingeschickt, nachdem ich versucht habe bzw. versucht gemacht wurd, manuell ein Speil zu betreten.

Nun zu meinem Problem:
Sobald ich ein Spiel zu betreten versuche, geht Siedler3 auf bis zum Bildschirm, auf dem steht man solle nichts mit Tastatur eingeben, danach minimiert sich Siedler, und der Fehler "Bitte an die Entwickler melden: Die neue Variante, das TCP/IP Protokoll zu laden ist fehlgeschlagen.Es wird jetzt versucht, die alte Variante zu nehmen.". Danach kommt die nächste Fehlermeldung "Zeitüberschreibung beim Laden des TCP/IP Protokolls in Siedler3".
Beim manuellen Spiel-entern lief anfangs alles OK, dann flog jemand, und im save war ich dann das Problem.

Mein Setup:
System: Bootcamp + Windows 10 (iMac 27", 4Ghz) - läuft sonst alles
Siedler: Siedler3 Original + MissionsCD + AmazonenCD + patch s160new - läuft, nur bei der Amazonen-CD mault er was von wegen nicht OriginalCD, wohl zu verkratzt
Ich: Kein Anfängerlein, Ingenieur/Programmierer/etc

Bereits versucht (gemäss TCP/IP Protokoll problem Artikel ):
- Re-install S3 und aLobby
- Install Java (separat)
- den Key brav eingeben im Multiplayer-lan modus bevor aLobby (läuft auch, mit Ausnahme der Amazonen-CD)

Auffälligkeiten in der Log-Datei:

(Ich paste erstmal ungern die ganze Datei, was da schon viel sensibles Zeug drinsteht)
Imho relevante Log-Einträge:
Code
20:21:31.318 CryptoSupport.decode(): ERROR, decryption failed! 
20:21:31.318 CryptoSupport.decode(null:-1): Exception: 
java.lang.IllegalArgumentException: Length of Base64 encoded input string is not a multiple of 4.
  at net.siedler3.alobby.util.Base64Coder.decode(Unknown Source)
  at net.siedler3.alobby.util.Base64Coder.decode(Unknown Source)
  at net.siedler3.alobby.util.CryptoSupport.decode(Unknown Source)
  at net.siedler3.alobby.util.CryptoSupport.decode(Unknown Source)
  at net.siedler3.alobby.communication.IRCCommunicator.onNotice(Unknown Source)
  at org.jibble.pircbot.PircBot.handleLine(Unknown Source)
  at org.jibble.pircbot.InputThread.run(InputThread.java:92)

Code
20:22:41.220 GameStarter.readyForMultiplayer(null:-1): Exception: 
java.lang.Exception: Zeit¸berschreitung beim Laden des TCP/IP Protokolls in Siedler3.
  at net.siedler3.alobby.s3gameinterface.GameStarter.chooseTCPIP(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.readyForMultiplayer(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.joinGame(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter$2.run(Unknown Source)
  at java.lang.Thread.run(Thread.java:748)

Code
20:23:04.125 GameStarter$2.run(null:-1): Exception: 
java.lang.Exception: Zeit¸berschreitung beim Laden des TCP/IP Protokolls in Siedler3.
  at net.siedler3.alobby.s3gameinterface.GameStarter.chooseTCPIP_old(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.readyForMultiplayer(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.joinGame(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter$2.run(Unknown Source)
  at java.lang.Thread.run(Thread.java:748)
1554834190113 PING :irc.siedler3.net
1554834190113 >>>PONG :irc.siedler3.net

Code
1554835090334 :duckyboy1990!duckyboy19@ANONYMIZED PRIVMSG Zwerg :geht?
20:38:10.357 S3InGameCheck.isInGame(): ingameCheck unsuccessful
20:38:19.311 GameStarter.chooseTCPIP(): ImageChecker f¸r TCP/IP fehlgeschlagen

Code
20:39:00.845 GameStarter.readyForMultiplayer(null:-1): Exception: 
java.lang.Exception: Zeit¸berschreitung beim Laden des TCP/IP Protokolls in Siedler3.
  at net.siedler3.alobby.s3gameinterface.GameStarter.chooseTCPIP(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.readyForMultiplayer(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.joinGame(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter$2.run(Unknown Source)
  at java.lang.Thread.run(Thread.java:748)

Code
20:39:26.901 GameStarter$2.run(null:-1): Exception: 
java.lang.Exception: Zeit¸berschreitung beim Laden des TCP/IP Protokolls in Siedler3.
  at net.siedler3.alobby.s3gameinterface.GameStarter.chooseTCPIP_old(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.readyForMultiplayer(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.joinGame(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter$2.run(Unknown Source)
  at java.lang.Thread.run(Thread.java:748)
1554835171153 PING :irc.siedler3.net
1554835171153 >>>PONG :irc.siedler3.net

Code
20:41:28.701 S3InGameCheck.isInGame(): ingameCheck unsuccessful

Code
1554835261929 :irc.siedler3.net 301 Zwerg duckyboy1990 :Ich bin im Spiel.
20:41:28.701 S3InGameCheck.isInGame(): ingameCheck unsuccessful

Code
20:52:01.825 GameStarter.startGame(): S3-Edition: 1
20:52:14.594 GameStarter.chooseTCPIP(): ImageChecker f¸r TCP/IP fehlgeschlagen

Code
20:53:20.691 GameStarter$2.run(null:-1): Exception: 
java.lang.Exception: Zeit¸berschreitung beim Laden des TCP/IP Protokolls in Siedler3.
  at net.siedler3.alobby.s3gameinterface.GameStarter.chooseTCPIP_old(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.readyForMultiplayer(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter.joinGame(Unknown Source)
  at net.siedler3.alobby.s3gameinterface.GameStarter$2.run(Unknown Source)
  at java.lang.Thread.run(Thread.java:748)


Bin grade paar Tage in der Schweiz, kann die Tipps dann erst ab Mo wieder testen.

Vielen Dank,
Zwerg

Ps. attachment function is buggy

Add:
Code


01:17:01.067 SettlersLobby.logSystemInfo(): aLobby 3.4.4, Windows 10 amd64, Java 1.8.0_202, 25.202-b08, C:\Program Files (x86)\aLobby\jre
C:\Program Files (x86)\aLobby

System Information
------------------
      Time of this report: 4/9/2019, 20:21:10
             Machine name: DESKTOP-O9V8AQ8
               Machine Id: {0D1A33A1-EAC3-4FCA-93C1-5128DB2A1971}
         Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
                 Language: German (Regional Setting: German)
      System Manufacturer: Apple Inc.
             System Model: iMac17,1
                     BIOS: IM171.88Z.0157.B00.1806261148 (type: UEFI)
                Processor: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
                   Memory: 16384MB RAM
      Available OS Memory: 16284MB RAM
                Page File: 4483MB used, 14744MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 192 DPI (200 percent)
       System DPI Setting: 288 DPI (300 percent)
          DWM DPI Scaling: Enabled
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
           DxDiag Version: 10.00.17134.0001 64bit Unicode

------------
DxDiag Notes
------------
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
          Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

     Name: Broadcom 802.11ac Network Adapter
Device ID: PCI\VEN_14E4&DEV_43BA&SUBSYS_014A106B&REV_01\31DC76FFFF5428F000
   Driver: C:\WINDOWS\system32\DRIVERS\BCMWL63a.SYS, 7.35.0118.0083 (English), 5/21/2018 16:59:52, 11195304 bytes
   Driver: C:\WINDOWS\system32\bcmihvsrv64.dll, 7.35.0118.0083 (English), 5/21/2018 16:59:52, 4143560 bytes
   Driver: C:\WINDOWS\system32\bcmihvui64.dll, 7.35.0118.0083 (English), 5/21/2018 16:59:53, 3787208 bytes

     Name: Broadcom NetXtreme Gigabit Ethernet
Device ID: PCI\VEN_14E4&DEV_1686&SUBSYS_168614E4&REV_01\000038C9864DE61E00
   Driver: C:\WINDOWS\system32\DRIVERS\b57nd60a.sys, 17.02.0001.0000 (English), 4/12/2018 01:33:49, 452608 bytes

Dieser Post wurde 1 mal bearbeitet. Letzte Editierung: 11.04.2019 - 13:44 Uhr von Zwerg.

Avatar Zwerg
keine Angabe keine Angabe

freier Siedler

Beiträge: 5
Dabei seit: 04 / 2019

Private Nachricht

11.04.2019 - 21:12 Uhr

Re: TCP/IP Probleme

Danke, das stand noch auf der to-try Liste. :whistle:

Registrierte in diesem Topic
Aktuell kein registrierter in diesem Bereich